Ask the Expert

My app can't find Web control DLLs

I have installed the MS Web controls and ran the Build.bat. I also created a folder named webctrl_client\1_0 under c:\inetpub\wwwroot. When I try to build some Web controls, I am still getting an error:
File or assembly name Microsoft.Web.UI.WebControls, or one of its dependencies, was not found.

Error found in Line 2:

<%@ Register TagPrefix="mytree" Namespace="Microsoft.Web.UI.WebControls">

So it can't find the Web control DLL's I assume. What am I doing wrong?
I don't see your Assembly attribute. It's required in order to locate the assembly where the control lives. If that doesn't solve the problem (or if you're already putting that in place), try manually adding the assembly to the GAC, using the .NET Framework configuration tool (inside Administrative Tools). Select Manage the Assembly Cache, then the Add an Assembly to the Assembly Cache. Locate the webcontrols DLL and that should do the trick.

This was first published in August 2003

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: